// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-val1-([^-]+)(?:-val2-([^-]+)|)(?:-val3-([^-]+)|)-").unwrap();
let string = "-val1-test-val2-result-val3-done-
-val1-test-val3-done-
-val1-test-val2-res-";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}