re = /-val1-([^-]+)(?:-val2-([^-]+)|)(?:-val3-([^-]+)|)-/
str = '-val1-test-val2-result-val3-done-
-val1-test-val3-done-
-val1-test-val2-res-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end