# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*\d*\:)?(\w+\.+\w..$)/$2/gm;t' <<< "*:443:domain.com
*:443:www.domain.com
"