const regex = /(.*\d*\:)?(\w+\.+\w..$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\d*\\:)?(\\w+\\.+\\w..$)', 'gm')
const str = `*:443:domain.com
*:443:www.domain.com
`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);