re = /(.*\d*\:)?(\w+\.+\w..$)/m
str = '*:443:domain.com
*:443:www.domain.com
'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result