import re
regex = re.compile(r"(.*\d*\:)?(\w+\.+\w..$)", flags=re.MULTILINE)
test_str = ("*:443:domain.com\n"
"*:443:www.domain.com\n")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)