package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\d*\:)?(\w+\.+\w..$)`)
var str = `*:443:domain.com
*:443:www.domain.com
`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}