use strict;
my $str = '*:443:domain.com
*:443:www.domain.com
';
my $regex = qr/(.*\d*\:)?(\w+\.+\w..$)/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";