#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(1[0-5]|16\.(1[1-5]|16\.(1[0-8]|190[0-3])))"
Local $sString = "16.17.18090901" & @CRLF & _
"16.16.19041201" & @CRLF & _
"15.33.17040900"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")