import re
regex = re.compile(r"^(1[0-5]|16\.(1[1-5]|16\.(1[0-8]|190[0-3])))")
test_str = ("16.17.18090901\n"
"16.16.19041201\n"
"15.33.17040900")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")