const regex = /^(1[0-5]|16\.(1[1-5]|16\.(1[0-8]|190[0-3])))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(1[0-5]|16\\.(1[1-5]|16\\.(1[0-8]|190[0-3])))', '')
const str = `16.17.18090901
16.16.19041201
15.33.17040900`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}