// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(1[0-5]|16\.(1[1-5]|16\.(1[0-8]|190[0-3])))").unwrap();
let string = "16.17.18090901
16.16.19041201
15.33.17040900";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}