import Foundation
let pattern = #"^(1[0-5]|16\.(1[1-5]|16\.(1[0-8]|190[0-3])))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
16.17.18090901
16.16.19041201
15.33.17040900
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}