$re = '/^(1[0-5]|16\.(1[1-5]|16\.(1[0-8]|190[0-3])))/';
$str = '16.17.18090901
16.16.19041201
15.33.17040900';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);