#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)^ " & @CRLF & _
"(?:" & @CRLF & _
" \s* " & @CRLF & _
" (?=" & @CRLF & _
" (?<! \S )" & @CRLF & _
" ( \S+ ) # (1)" & @CRLF & _
" )?" & @CRLF & _
" \S " & @CRLF & _
"){1}" & @CRLF & _
""
Local $sString = "This is my very boring string" & @CRLF & _
"0123 45 67 8901 234567 8" & @CRLF & _
"0 1 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")