// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)^
(?:
\s*
(?=
(?<! \S )
( \S+ ) # (1)
)?
\S
){1}
").unwrap();
let string = "This is my very boring string
0123 45 67 8901 234567 8
0 1 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}