package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^
(?:
\s*
(?=
(?<! \S )
( \S+ ) # (1)
)?
\S
){1}
`)
var str = `This is my very boring string
0123 45 67 8901 234567 8
0 1 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}