re = /^
(?:
\s*
(?=
(?<! \S )
( \S+ ) # (1)
)?
\S
){1}
/x
str = 'This is my very boring string
0123 45 67 8901 234567 8
0 1 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end