const regex = new RegExp('^
(?:
\\s*
(?=
(?<! \\S )
( \\S+ ) # (1)
)?
\\S
){1}
', 'g')
const str = `This is my very boring string
0123 45 67 8901 234567 8
0 1 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}