import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ \n"
+ "(?:\n"
+ " \\s* \n"
+ " (?=\n"
+ " (?<! \\S )\n"
+ " ( \\S+ ) # (1)\n"
+ " )?\n"
+ " \\S \n"
+ "){1}\n";
final String string = "This is my very boring string\n"
+ "0123 45 67 8901 234567 8\n"
+ "0 1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}