using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
(?:
\s*
(?=
(?<! \S )
( \S+ ) # (1)
)?
\S
){1}
";
string input = @"This is my very boring string
0123 45 67 8901 234567 8
0 1 ";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}