$re = '/^
(?:
\s*
(?=
(?<! \S )
( \S+ ) # (1)
)?
\S
){1}
/x';
$str = 'This is my very boring string
0123 45 67 8901 234567 8
0 1 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);