# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<PREFIX>somestring)\d*/${PREFIX}1000/gu;t' <<< "somestring1234"