// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(?<PREFIX>somestring)\d*").unwrap();
let string = "somestring1234";
let substitution = "${PREFIX}1000";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}