re = /(?<PREFIX>somestring)\d*/
str = 'somestring1234'
subst = '${PREFIX}1000'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result