package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<PREFIX>somestring)\d*`)
var str = `somestring1234`
var substitution = "${PREFIX}1000"
fmt.Println(re.ReplaceAllString(str, substitution))
}