const regex = /[,.!?]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[,.!?]', 'g')
const str = `This is a test for replacing characters:
Dots..., question marks?, exclamation marks!
And of course, the comma.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);