use strict;
my $str = 'This is a test for replacing characters:
Dots..., question marks?, exclamation marks!
And of course, the comma.';
my $regex = qr/[,.!?]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";