// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[,.!?]").unwrap();
let string = "This is a test for replacing characters:
Dots..., question marks?, exclamation marks!
And of course, the comma.";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}