re = /[,.!?]/
str = 'This is a test for replacing characters:
Dots..., question marks?, exclamation marks!
And of course, the comma.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result