# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(xyz(?:(?!abc).)*?)123/$1456/gms;t' <<< "abc----1
pqr----2
123----3
xyz----4
lll----5
pqr----6
123----7
qqq----8
xyz----5
abc----3
123----9"