using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(xyz(?:(?!abc).)*?)123";
string substitution = @"$1456";
string input = @"abc----1
pqr----2
123----3
xyz----4
lll----5
pqr----6
123----7
qqq----8
xyz----5
abc----3
123----9";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}