use strict;
my $str = 'abc----1
pqr----2
123----3
xyz----4
lll----5
pqr----6
123----7
qqq----8
xyz----5
abc----3
123----9';
my $regex = qr/(xyz(?:(?!abc).)*?)123/msp;
my $subst = '$1456';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";