# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(xyz(?:(?!abc).)*?)123"
test_str = ("abc----1\n"
"pqr----2\n"
"123----3\n"
"xyz----4\n"
"lll----5\n"
"pqr----6\n"
"123----7\n"
"qqq----8\n"
"xyz----5\n"
"abc----3\n"
"123----9")
subst = "$1456"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.