import Foundation
let pattern = #"(xyz(?:(?!abc).)*?)123"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
abc----1
pqr----2
123----3
xyz----4
lll----5
pqr----6
123----7
qqq----8
xyz----5
abc----3
123----9
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1456"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)