import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(xyz(?:(?!abc).)*?)123";
final String string = "abc----1\n"
+ "pqr----2\n"
+ "123----3\n"
+ "xyz----4\n"
+ "lll----5\n"
+ "pqr----6\n"
+ "123----7\n"
+ "qqq----8\n"
+ "xyz----5\n"
+ "abc----3\n"
+ "123----9";
final String subst = "$1456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}