re = /(xyz(?:(?!abc).)*?)123/m
str = 'abc----1
pqr----2
123----3
xyz----4
lll----5
pqr----6
123----7
qqq----8
xyz----5
abc----3
123----9'
subst = '$1456'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result