const regex = /(xyz(?:(?!abc).)*?)123/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(xyz(?:(?!abc).)*?)123', 'gms')
const str = `abc----1
pqr----2
123----3
xyz----4
lll----5
pqr----6
123----7
qqq----8
xyz----5
abc----3
123----9`;
const subst = `$1456`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);