using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<TransactionID>(?<transID>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode>.*?)<\/ActionCode>.*?<Token>(?<token>.*?)<\/Token>.*?<Approval>(?<approv>.*?)<\/Approval>.*?<CVV2>(?<cvv>.*?)<\/CVV2>.*?<ResponseText>(?<respon>.*?)<\/ResponseText>.*?<VerificationResult>(?<verify>.*?)<\/VerificationResult>|<TransactionID>(?<transID2>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode2>.*?)<\/ActionCode>.*?<ResponseText>(?<respon2>.*?)<\/ResponseText>";
string input = @"<ippayResponse><TransactionID>K20201022144133757</TransactionID><ActionCode>000</ActionCode><Token>4E3C5K3B7H0A1000</Token><Approval>TEST35</Approval><CVV2>N</CVV2><ResponseText>APPROVED</ResponseText><VerificationResult>0</VerificationResult></ippayResponse>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}