re = /<TransactionID>(?<transID>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode>.*?)<\/ActionCode>.*?<Token>(?<token>.*?)<\/Token>.*?<Approval>(?<approv>.*?)<\/Approval>.*?<CVV2>(?<cvv>.*?)<\/CVV2>.*?<ResponseText>(?<respon>.*?)<\/ResponseText>.*?<VerificationResult>(?<verify>.*?)<\/VerificationResult>|<TransactionID>(?<transID2>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode2>.*?)<\/ActionCode>.*?<ResponseText>(?<respon2>.*?)<\/ResponseText>/m
str = '<ippayResponse><TransactionID>K20201022144133757</TransactionID><ActionCode>000</ActionCode><Token>4E3C5K3B7H0A1000</Token><Approval>TEST35</Approval><CVV2>N</CVV2><ResponseText>APPROVED</ResponseText><VerificationResult>0</VerificationResult></ippayResponse>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end