import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<TransactionID>(?<transID>.*?)<\\/TransactionID>.*?<ActionCode>(?<actcode>.*?)<\\/ActionCode>.*?<Token>(?<token>.*?)<\\/Token>.*?<Approval>(?<approv>.*?)<\\/Approval>.*?<CVV2>(?<cvv>.*?)<\\/CVV2>.*?<ResponseText>(?<respon>.*?)<\\/ResponseText>.*?<VerificationResult>(?<verify>.*?)<\\/VerificationResult>|<TransactionID>(?<transID2>.*?)<\\/TransactionID>.*?<ActionCode>(?<actcode2>.*?)<\\/ActionCode>.*?<ResponseText>(?<respon2>.*?)<\\/ResponseText>";
final String string = "<ippayResponse><TransactionID>K20201022144133757</TransactionID><ActionCode>000</ActionCode><Token>4E3C5K3B7H0A1000</Token><Approval>TEST35</Approval><CVV2>N</CVV2><ResponseText>APPROVED</ResponseText><VerificationResult>0</VerificationResult></ippayResponse>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}