const regex = /<TransactionID>(?<transID>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode>.*?)<\/ActionCode>.*?<Token>(?<token>.*?)<\/Token>.*?<Approval>(?<approv>.*?)<\/Approval>.*?<CVV2>(?<cvv>.*?)<\/CVV2>.*?<ResponseText>(?<respon>.*?)<\/ResponseText>.*?<VerificationResult>(?<verify>.*?)<\/VerificationResult>|<TransactionID>(?<transID2>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode2>.*?)<\/ActionCode>.*?<ResponseText>(?<respon2>.*?)<\/ResponseText>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<TransactionID>(?<transID>.*?)<\\\/TransactionID>.*?<ActionCode>(?<actcode>.*?)<\\\/ActionCode>.*?<Token>(?<token>.*?)<\\\/Token>.*?<Approval>(?<approv>.*?)<\\\/Approval>.*?<CVV2>(?<cvv>.*?)<\\\/CVV2>.*?<ResponseText>(?<respon>.*?)<\\\/ResponseText>.*?<VerificationResult>(?<verify>.*?)<\\\/VerificationResult>|<TransactionID>(?<transID2>.*?)<\\\/TransactionID>.*?<ActionCode>(?<actcode2>.*?)<\\\/ActionCode>.*?<ResponseText>(?<respon2>.*?)<\\\/ResponseText>', 'gm')
const str = `<ippayResponse><TransactionID>K20201022144133757</TransactionID><ActionCode>000</ActionCode><Token>4E3C5K3B7H0A1000</Token><Approval>TEST35</Approval><CVV2>N</CVV2><ResponseText>APPROVED</ResponseText><VerificationResult>0</VerificationResult></ippayResponse>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}