// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<TransactionID>(?<transID>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode>.*?)<\/ActionCode>.*?<Token>(?<token>.*?)<\/Token>.*?<Approval>(?<approv>.*?)<\/Approval>.*?<CVV2>(?<cvv>.*?)<\/CVV2>.*?<ResponseText>(?<respon>.*?)<\/ResponseText>.*?<VerificationResult>(?<verify>.*?)<\/VerificationResult>|<TransactionID>(?<transID2>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode2>.*?)<\/ActionCode>.*?<ResponseText>(?<respon2>.*?)<\/ResponseText>").unwrap();
let string = "<ippayResponse><TransactionID>K20201022144133757</TransactionID><ActionCode>000</ActionCode><Token>4E3C5K3B7H0A1000</Token><Approval>TEST35</Approval><CVV2>N</CVV2><ResponseText>APPROVED</ResponseText><VerificationResult>0</VerificationResult></ippayResponse>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}