import re
regex = re.compile(r"<TransactionID>(?<transID>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode>.*?)<\/ActionCode>.*?<Token>(?<token>.*?)<\/Token>.*?<Approval>(?<approv>.*?)<\/Approval>.*?<CVV2>(?<cvv>.*?)<\/CVV2>.*?<ResponseText>(?<respon>.*?)<\/ResponseText>.*?<VerificationResult>(?<verify>.*?)<\/VerificationResult>|<TransactionID>(?<transID2>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode2>.*?)<\/ActionCode>.*?<ResponseText>(?<respon2>.*?)<\/ResponseText>", flags=re.MULTILINE)
test_str = "<ippayResponse><TransactionID>K20201022144133757</TransactionID><ActionCode>000</ActionCode><Token>4E3C5K3B7H0A1000</Token><Approval>TEST35</Approval><CVV2>N</CVV2><ResponseText>APPROVED</ResponseText><VerificationResult>0</VerificationResult></ippayResponse>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")