#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s+Fixed version\s+:\s+(?<FixedVersion>[^\n\r\<]+)"
Local $sString = "<plugin_output>" & @CRLF & _
" Path : C:\Program Files\VMware\VMware Tools\VMware VGAuth\libssl-3-x64.dll" & @CRLF & _
" Reported version : 3.0.3.0" & @CRLF & _
" Fixed version : 3.0.4</plugin_output>" & @CRLF & _
"<plugin_output>" & @CRLF & _
" Path : C:\myPrograms\cygwin64\bin\openssl.exe " & @CRLF & _
" Reported version : 1.1.1.4 " & @CRLF & _
" Fixed version : 1.1.1p " & @CRLF & _
"" & @CRLF & _
" Path : C:\myPrograms\Git\usr\bin\openssl.exe " & @CRLF & _
" Reported version : 1.1.1.9 " & @CRLF & _
" Fixed version : 1.1.1p " & @CRLF & _
"" & @CRLF & _
" Path : C:\myPrograms\Git\mingw64\bin\openssl.exe " & @CRLF & _
" Reported version : 1.1.1.9 " & @CRLF & _
" Fixed version : 1.1.1p " & @CRLF & _
"</plugin_output>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")