import re
regex = re.compile(r"\s+Fixed version\s+:\s+(?<FixedVersion>[^\n\r\<]+)", flags=re.MULTILINE)
test_str = ("<plugin_output>\n"
" Path : C:\\Program Files\\VMware\\VMware Tools\\VMware VGAuth\\libssl-3-x64.dll\n"
" Reported version : 3.0.3.0\n"
" Fixed version : 3.0.4</plugin_output>\n"
"<plugin_output>\n"
" Path : C:\\myPrograms\\cygwin64\\bin\\openssl.exe \n"
" Reported version : 1.1.1.4 \n"
" Fixed version : 1.1.1p \n\n"
" Path : C:\\myPrograms\\Git\\usr\\bin\\openssl.exe \n"
" Reported version : 1.1.1.9 \n"
" Fixed version : 1.1.1p \n\n"
" Path : C:\\myPrograms\\Git\\mingw64\\bin\\openssl.exe \n"
" Reported version : 1.1.1.9 \n"
" Fixed version : 1.1.1p \n"
"</plugin_output>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")