use strict;
my $str = '<plugin_output>
Path : C:\\Program Files\\VMware\\VMware Tools\\VMware VGAuth\\libssl-3-x64.dll
Reported version : 3.0.3.0
Fixed version : 3.0.4</plugin_output>
<plugin_output>
Path : C:\\myPrograms\\cygwin64\\bin\\openssl.exe
Reported version : 1.1.1.4
Fixed version : 1.1.1p
Path : C:\\myPrograms\\Git\\usr\\bin\\openssl.exe
Reported version : 1.1.1.9
Fixed version : 1.1.1p
Path : C:\\myPrograms\\Git\\mingw64\\bin\\openssl.exe
Reported version : 1.1.1.9
Fixed version : 1.1.1p
</plugin_output>
';
my $regex = qr/\s+Fixed version\s+:\s+(?<FixedVersion>[^\n\r\<]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}