// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+Fixed version\s+:\s+(?<FixedVersion>[^\n\r\<]+)").unwrap();
let string = "<plugin_output>
Path : C:\\Program Files\\VMware\\VMware Tools\\VMware VGAuth\\libssl-3-x64.dll
Reported version : 3.0.3.0
Fixed version : 3.0.4</plugin_output>
<plugin_output>
Path : C:\\myPrograms\\cygwin64\\bin\\openssl.exe
Reported version : 1.1.1.4
Fixed version : 1.1.1p
Path : C:\\myPrograms\\Git\\usr\\bin\\openssl.exe
Reported version : 1.1.1.9
Fixed version : 1.1.1p
Path : C:\\myPrograms\\Git\\mingw64\\bin\\openssl.exe
Reported version : 1.1.1.9
Fixed version : 1.1.1p
</plugin_output>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}