import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+Fixed version\\s+:\\s+(?<FixedVersion>[^\\n\\r\\<]+)";
final String string = "<plugin_output>\n"
+ " Path : C:\\Program Files\\VMware\\VMware Tools\\VMware VGAuth\\libssl-3-x64.dll\n"
+ " Reported version : 3.0.3.0\n"
+ " Fixed version : 3.0.4</plugin_output>\n"
+ "<plugin_output>\n"
+ " Path : C:\\myPrograms\\cygwin64\\bin\\openssl.exe \n"
+ " Reported version : 1.1.1.4 \n"
+ " Fixed version : 1.1.1p \n\n"
+ " Path : C:\\myPrograms\\Git\\usr\\bin\\openssl.exe \n"
+ " Reported version : 1.1.1.9 \n"
+ " Fixed version : 1.1.1p \n\n"
+ " Path : C:\\myPrograms\\Git\\mingw64\\bin\\openssl.exe \n"
+ " Reported version : 1.1.1.9 \n"
+ " Fixed version : 1.1.1p \n"
+ "</plugin_output>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}