import Foundation
let pattern = #"\s+Fixed version\s+:\s+(?<FixedVersion>[^\n\r\<]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<plugin_output>
Path : C:\Program Files\VMware\VMware Tools\VMware VGAuth\libssl-3-x64.dll
Reported version : 3.0.3.0
Fixed version : 3.0.4</plugin_output>
<plugin_output>
Path : C:\myPrograms\cygwin64\bin\openssl.exe
Reported version : 1.1.1.4
Fixed version : 1.1.1p
Path : C:\myPrograms\Git\usr\bin\openssl.exe
Reported version : 1.1.1.9
Fixed version : 1.1.1p
Path : C:\myPrograms\Git\mingw64\bin\openssl.exe
Reported version : 1.1.1.9
Fixed version : 1.1.1p
</plugin_output>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)